Bench testing MCR games

  • The pin called V. BATT needs to be connected to +5V if you're not using the original power supply.
  • Trying to power the sound section using the same switching power supply as the rest of your bench testing setup will not work well. This forces you to connect digital ground and analog ground and will result in crazy audio hum that drowns out the sounds. My recommendation is to grab another 12VDC wall wart and wire it up to the same connector that outputs audio. Check the schematics and you'll see that 12V and AGND can be connected there. The audio is not amplified here so you'll need powered speakers.
  • The filter circuitry on the board interferes with the Channel Test. Even on a fully working SSIO board you'll get some noise if the filter circuit is running. On my three SSIO boards, Channel 5 was noisy while the rest were quiet. You can disable the filter circuits simply by removing the 82S123 PROM during testing.


I was repairing a Wacko boardset that was dead. I fixed various problems on all three boards (SSIO which is sound and input/output, the Super CPU board, and the Video Generator III) but got to a point where just about everything looked good except for two problems:

1. A few random black lines were showing up to the left of some sprites. This ended up being the group of four 2101 SRAM, and in fact the chips were fine but must have different timing. Swapping them with another manufacturer seemed to do the trick. AMD worked well, Cypress did not.

2. There are a few sprite errors during the demo sequence. I spent a lot of time checking this, and eventually bought another MCR board set from eBay. After doing a lot of swapping, I was quite sure that the only possibility of error could be the ROMs themselves. However, they tested fine in several different EPROM testers that I had. Finally, I asked over on the KLOV forums, and another owner of a Wacko board confirmed that indeed these errors are present on all boards.

Kozmik Kroozr

After getting the Wacko going, I thought I would finish up the board I bought from eBay, which came with Kozmik Kroozr ROMs. Since the MCR games that use identical boards can all just be ROM swapped, I could have just swapped with the Wacko ROMs or whatever, but I was curious so I pushed on. So when trying to boot the game, it would do a reset sequence then just sit on this green grid. I tried many things to get it to boot further, and very occasionally, it would boot into the game but crash. This was a false positive! On the Arcade Museum page, there is a technical note that the game will not boot past the green grid if it doesn't detect a sensor from the toy spaceship that is part of the machine. For future reference, this is J4 pin 13 that must be grounded to boot the game.